aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorBastien Nocera2002-05-10 17:44:16 +0000
committerBastien Nocera2002-05-10 17:44:16 +0000
commit36acc99ae1631433f286dde703c89f7fe95679c7 (patch)
tree58ba7b2f71343b28dc8c2c3007f7fc879cbdcef3 /debian
parentc72ceda700dff760a90ff701aaf32a37829be9eb (diff)
downloadscummvm-rg350-36acc99ae1631433f286dde703c89f7fe95679c7.tar.gz
scummvm-rg350-36acc99ae1631433f286dde703c89f7fe95679c7.tar.bz2
scummvm-rg350-36acc99ae1631433f286dde703c89f7fe95679c7.zip
- removed wrapper script, re-added missing debian files (ooops!), added a README.Debian with some info about the config file for Ender
svn-id: r4269
Diffstat (limited to 'debian')
-rw-r--r--debian/README.Debian9
-rw-r--r--debian/control15
-rw-r--r--debian/copyright16
-rwxr-xr-xdebian/rules48
-rw-r--r--debian/scummvm.docs2
-rwxr-xr-xdebian/scummvm.sh51
6 files changed, 90 insertions, 51 deletions
diff --git a/debian/README.Debian b/debian/README.Debian
new file mode 100644
index 0000000000..5394ccae26
--- /dev/null
+++ b/debian/README.Debian
@@ -0,0 +1,9 @@
+scummvm for Debian
+------------------
+
+ There is no documentation for the configuration file. For now you can use:
+ scummvm -w -p[path] [options] game
+ it will write a config file in ~/.scummvmrc and from then on you can just
+ run 'scummvm game' and it will remember your options
+
+ -- Bastien Nocera <hadess@hadess.net>, Friday 10 May 2002
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000000..f2ffa3a003
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,15 @@
+Source: scummvm
+Section: contrib/games
+Priority: optional
+Maintainer: Bastien Nocera <hadess@hadess.net>
+Build-Depends: debhelper (>> 3.0.0), libsdl1.2-dev, libreadline4-dev, libncurses5-dev
+Standards-Version: 3.5.2
+
+Package: scummvm
+Architecture: any
+Depends: ${shlibs:Depends}
+Description: Engine to run some LucasArts adventure games
+ The "Script Creation Utility for Maniac Mansion Virtual Machine" (scummvm for
+ short) is an engine used to run a lot of LucasArts adventure games.
+ .
+ You will also need the data files from the game to be able to play it.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000000..ef03344742
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,16 @@
+This package was debianized by Bastien Nocera <hadess@hadess.net> on
+Fri, 5 Apr 2002 16:37:09 +0100.
+
+It was downloaded from http://prdownloads.sourceforge.net/scummvm/
+
+Upstream Author(s): ScummVM team <scummvm-devel@lists.sourceforge.net>
+
+Copyright:
+
+This program is free software; you can redistribute it and/or modify it
+under the terms of the GNU General Public License as published by the
+Free Software Foundation; either version 2, or (at your option) any
+later version.
+
+On Debian GNU/Linux systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL'.
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000000..b05473cabc
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,48 @@
+#!/usr/bin/make -f
+
+export DH_COMPAT=3
+
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -g
+endif
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+ INSTALL_PROGRAM += -s
+endif
+
+build:
+ dh_testdir
+ $(MAKE)
+
+clean:
+ dh_testdir
+ dh_testroot
+ -$(MAKE) clean
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ install -m0777 scummvm $(CURDIR)/debian/scummvm/usr/games/scummvm
+ install -m0644 scummvm.6 \
+ $(CURDIR)/debian/scummvm/usr/share/man/man6
+
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installdocs
+ dh_installchangelogs
+ dh_installmanpages scummvm.6
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-arch
+.PHONY: build clean binary-arch binary install
diff --git a/debian/scummvm.docs b/debian/scummvm.docs
new file mode 100644
index 0000000000..6e88c596f4
--- /dev/null
+++ b/debian/scummvm.docs
@@ -0,0 +1,2 @@
+readme.txt
+whatsnew.txt
diff --git a/debian/scummvm.sh b/debian/scummvm.sh
deleted file mode 100755
index 110773eb7d..0000000000
--- a/debian/scummvm.sh
+++ /dev/null
@@ -1,51 +0,0 @@
-#!/bin/sh
-
-# Uncomment this to debug the script
-# set -x
-
-DIR=$1
-
-help()
-{
- echo "Scummvm wrapper by Bastien Nocera <hadess@hadess.net>"
- echo "Usage:"
- echo " `basename $0` [dir|file]"
- echo "Options:"
- echo " dir path to a directory containing a supported game"
- echo " file one of the file in a directory containing a supported game"
- echo
- exit
-}
-
-if [ $# -ne 1 ] ; then help ; fi
-if [ $1 == "-h" ] ; then help ; fi
-if [ ! -d $1 ] ; then\
- if [ -e $1 ] ; then
- DIR=`dirname $1`
- else
- help
- fi
-fi
-
-# Here we check for which game we're gonna be running
-if [ -e $DIR/*.000 ] ; then
- GAME=`basename $DIR/*.000 | sed 's,.000$,,g' | grep -v '*'`
- if [ x$GAME = 'x' ] ; then
- echo "*** Game not found ***"
- help
- fi
-fi
-
-
-# Check for the game, see if it's supported
-if [ -z $GAME ] ; then
- echo "*** Unsupported game ***"
- help
-fi
-
-# Go to the game's dir
-cd $DIR
-
-# Launch scummvm with the game name
-/usr/lib/scummvm/scummvm $GAME
-