aboutsummaryrefslogtreecommitdiff
path: root/dists/debian/prepare
diff options
context:
space:
mode:
authorTore Anderson2005-07-18 21:53:48 +0000
committerTore Anderson2005-07-18 21:53:48 +0000
commit7c0720e5dcba4bcd2eb40f68fffca8e859c49c1f (patch)
tree82edd70d10e44e634ee385b449f52a984b2b94bc /dists/debian/prepare
parentd3ba7a1543df7071a0971da773f998c2888c2f61 (diff)
downloadscummvm-rg350-7c0720e5dcba4bcd2eb40f68fffca8e859c49c1f.tar.gz
scummvm-rg350-7c0720e5dcba4bcd2eb40f68fffca8e859c49c1f.tar.bz2
scummvm-rg350-7c0720e5dcba4bcd2eb40f68fffca8e859c49c1f.zip
Synchronized dists/debian with what's in the official Debian archives.
svn-id: r18554
Diffstat (limited to 'dists/debian/prepare')
-rwxr-xr-xdists/debian/prepare35
1 files changed, 33 insertions, 2 deletions
diff --git a/dists/debian/prepare b/dists/debian/prepare
index 095c596854..db2a141c3d 100755
--- a/dists/debian/prepare
+++ b/dists/debian/prepare
@@ -1,5 +1,36 @@
#! /bin/sh
-VER=`sed -n -e 's/^const char \*gScummVMVersion = "\(.*\)";/\1/p' base/main.cpp``date +%Y%m%d`
+# This simple script is called from the upstream makefile whenever someone
+# calls "make deb". It adds a changelog entry to the top of debian/changelog
+# so that the version number is correct.
-sed "s/@VERSION@/$VER/g" debian/changelog.in > debian/changelog
+VERSION=`sed -n -e 's/CVS//g' -e 's/^const char \*gScummVMVersion = "\(.*\)";/\1/p' base/main.cpp `-0cvs`date +%Y%m%d`
+USERNAME=`whoami`
+GECOS=`getent passwd $USERNAME | awk '-F[,:]' '{print $5}'`
+DOMAIN=`hostname --fqdn`
+DATE=`date -R`
+
+head -1 debian/changelog | grep -qF $VERSION && exit 0
+
+TMP=`tempfile`
+
+cat debian/changelog > $TMP
+
+cat << __eof > debian/changelog
+scummvm ($VERSION) experimental; urgency=low
+
+ * CVS snapshot.
+
+ Builder: $GECOS <$USERNAME@$DOMAIN>
+ Build-date: $DATE
+
+ Please don't file bugs you find in this package in the Debian Bug Tracking
+ system, use the ScummVM team's own bug tracker instead. You can find this
+ tracker at <http://sourceforge.net/tracker/?group_id=37116>.
+
+ -- Tore Anderson <tore@debian.org> $DATE
+
+__eof
+
+cat $TMP >> debian/changelog
+rm -f $TMP