aboutsummaryrefslogtreecommitdiff
path: root/debian/prepare
diff options
context:
space:
mode:
Diffstat (limited to 'debian/prepare')
-rwxr-xr-xdebian/prepare8
1 files changed, 6 insertions, 2 deletions
diff --git a/debian/prepare b/debian/prepare
index 63384fe647..0698be1184 100755
--- a/debian/prepare
+++ b/debian/prepare
@@ -5,12 +5,16 @@ if [ ! -e debian/rules ] ; then
exit 1
fi
-if [ -d CVS/ ] ; then
+if [ -d CVS/ ] && [ $1 != "--nocvs" ]; then
TODATE=`date +%Y%m%d`
NEXT_VERSION=`grep SCUMMVM_VERSION scumm.h | sed 's,\#define\ SCUMMVM_VERSION\ \",,gi' | sed 's,\ devel\",,gi'`
cat debian/changelog.cvs | sed s/@VERSION@/$NEXT_VERSION.cvs$TODATE/g \
> debian/changelog.tmp && mv debian/changelog.tmp debian/changelog
exit 0
else
- cp debian/changelog.debian debian/changelog
+ if [ x$USER = xhadess ]; then
+ cp debian/changelog.debian_official debian/changelog
+ else
+ cp debian/changelog.debian debian/changelog
+ fi
fi