aboutsummaryrefslogtreecommitdiff
path: root/dists/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'dists/debian/rules')
-rwxr-xr-xdists/debian/rules50
1 files changed, 50 insertions, 0 deletions
diff --git a/dists/debian/rules b/dists/debian/rules
new file mode 100755
index 0000000000..8bd7b6989b
--- /dev/null
+++ b/dists/debian/rules
@@ -0,0 +1,50 @@
+#!/usr/bin/make -f
+
+export DH_COMPAT=3
+
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+ export CFLAGS += -g
+endif
+
+build:
+ dh_testdir
+ $(MAKE)
+
+clean:
+ dh_testdir
+ dh_testroot
+ -$(MAKE) clean
+ -find . -type d -name .deps | xargs rm -rf
+ rm -f build.rules
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean
+ dh_installdirs
+ install -m0755 scummvm $(CURDIR)/debian/scummvm-cvs/usr/games/scummvm
+ install -m0644 scummvm.xpm $(CURDIR)/debian/scummvm-cvs/usr/share/icons
+
+binary: binary-arch binary-indep
+
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installdocs
+ dh_installchangelogs NEWS
+ dh_installman
+ dh_installmenu
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary-indep:
+
+.PHONY: build clean binary install binary-arch binary-indep