aboutsummaryrefslogtreecommitdiff
path: root/engines/lab/tilepuzzle.cpp
AgeCommit message (Expand)Author
2015-12-27LAB: Rename TilePuzzle to SpecialLocks, to better reflect its purposeFilippos Karapetis
2015-12-27LAB: Fix crash in the the door number puzzleFilippos Karapetis
2015-12-26LAB: Clean up Image._imageData memory handlingWillem Jan Palenstijn
2015-12-24LAB: Merge setPen() into rectFill()Filippos Karapetis
2015-12-24LAB: Prevent the Image destructor from deleting the drawing bufferFilippos Karapetis
2015-12-23LAB: Use int in for loops, instead of uint16Filippos Karapetis
2015-12-23LAB: Remove left-over long size specifiersStrangerke
2015-12-23LAB: Move some more comments to header filesStrangerke
2015-12-23LAB: Set a default to the second parameter of readPictStrangerke
2015-12-23LAB: Some cleanup and refactoringStrangerke
2015-12-23LAB: Better handling of the Trial check in the puzzleStrangerke
2015-12-23LAB: Some renaming in DisplayManStrangerke
2015-12-23LAB: Reduced scope of a few more variablesEugene Sandulenko
2015-12-23LAB: Add _vm to Image classStrangerke
2015-12-23LAB: Move some defines which are only used in the tile puzzleFilippos Karapetis
2015-12-23LAB: Move all the tile puzzle related functionality into its own classFilippos Karapetis
2015-12-23LAB: Use a local buffer for moving tiles in the tile puzzleFilippos Karapetis
2015-12-23LAB: Reduced last reducable header: anim.hEugene Sandulenko
2015-12-23LAB: Reduced header dependency: dispman.h, eventman.hEugene Sandulenko
2015-12-23LAB: More header dependency reduxEugene Sandulenko
2015-12-23LAB: Reduced header dependency: labsets.h, utils.hEugene Sandulenko
2015-12-23LAB: Reduce header intra-dependency. Reduced image.h dependencyEugene Sandulenko
2015-12-23LAB: Use // for commentsStrangerke
2015-12-23LAB: Use doxygen format for function commentsStrangerke
2015-12-23LAB: Some more refactoring and renamingStrangerke
2015-12-23LAB: Refactoring the vgaUnscale code and the way it's usedStrangerke
2015-12-23LAB: Fix some coding style in tilepuzzleStrangerke
2015-12-23LAB: Move utility functions to a separate classStrangerke
2015-12-23LAB: Some refactoring, remove dead code and a useless return valueStrangerke
2015-12-23LAB: Move fade functions to DisplayMan, some renamingStrangerke
2015-12-23LAB: Move more functions to DisplayManStrangerke
2015-12-23LAB: Simplify several calls to flowText() and rectFill()Filippos Karapetis
2015-12-23LAB: Split the tile puzzle related functions into a separate fileFilippos Karapetis