Age | Commit message (Collapse) | Author |
|
Refactoring, no changes in behaviour.
|
|
Merge SoundFlag and SoundStatus into a single enum;
SoundEntry::setupStatus just casts one to another.
Keep only definitions of bits in SoundFlag; drop compound flags
like kFlagSteam = kSoundTypeAmbient | kSoundFlagLooped | kVolume7,
use ORed simple flags in calls; change the signature
of SoundManager::playSoundWithSubtitles to use uint32
instead of SoundFlag to avoid excess casting.
Add meaningful names to flags; add some comments.
Get rid of endian-unsafe SoundStatusUnion.
Fixes an issue with big-endian hosts.
No changes in behaviour on little-endian hosts.
|
|
|
|
|
|
- Implement missing queue reset function
- Cleanup SoundManager::playLoopingSound()
|
|
- Move entry-related functions to separate class
- Move enumeration to shared header and rename FlagType to SoundFlag
|
|
- Replace structs holding function pointers by proper classes
- Move each fighter functions to separate files
|