aboutsummaryrefslogtreecommitdiff
path: root/modules/mod_m7/Makefile.am
diff options
context:
space:
mode:
authorneonloop2021-10-20 14:54:27 +0000
committerneonloop2021-10-20 14:54:27 +0000
commitea1947ffcc606d757357398b24e74a3f4ecefa07 (patch)
tree2031b8d4fc4c61063c710a7148378f57e662efbd /modules/mod_m7/Makefile.am
downloadbennugd-main.tar.gz
bennugd-main.tar.bz2
bennugd-main.zip
Initial commit from steward-fu releasemain
Diffstat (limited to 'modules/mod_m7/Makefile.am')
-rw-r--r--modules/mod_m7/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/modules/mod_m7/Makefile.am b/modules/mod_m7/Makefile.am
new file mode 100644
index 0000000..95b400a
--- /dev/null
+++ b/modules/mod_m7/Makefile.am
@@ -0,0 +1,14 @@
+## Process this file with automake to produce Makefile.in
+
+#AUTOMAKE_OPTIONS = no-dependencies foreign
+
+lib_LTLIBRARIES = libmod_m7.la
+
+libmod_m7_la_SOURCES = mod_m7.c
+libmod_m7_la_CFLAGS = $(COMMON_CFLAGS) $(SDL_CFLAGS) -I$(BGD_PATH)/include -I$(BGD_PATH)/bgdrtm/include -I../librender/ -I../libblit/ -I../libvideo/ -I../libgrbase/
+libmod_m7_la_LDFLAGS = -s -module -no-undefined -avoid-version
+libmod_m7_la_LIBADD = $(COMMON_LDFLAGS) -L$(BGD_PATH)/bgdrtm/src/.libs -lbgdrtm -L../libvideo/.libs -lvideo -L../librender/.libs -lrender -L../libgrbase/.libs -lgrbase
+
+## Make sure these will be cleaned even when they're not built by
+## default.
+CLEANFILES = libmod_m7.la