aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorBastien Nocera2002-05-15 02:49:32 +0000
committerBastien Nocera2002-05-15 02:49:32 +0000
commit11cda19c37a4092ce5632f03527963c1f4a28914 (patch)
treed88bf44c089edaada08237984a4d0379916bfcae /debian
parent885f043a7f0966ba5f0d43eef0760a0e6fd563d4 (diff)
downloadscummvm-rg350-11cda19c37a4092ce5632f03527963c1f4a28914.tar.gz
scummvm-rg350-11cda19c37a4092ce5632f03527963c1f4a28914.tar.bz2
scummvm-rg350-11cda19c37a4092ce5632f03527963c1f4a28914.zip
- added the official debian changelog, that nobody apart from me should modify. This should allow Ender to make releases of his own, and me still having the changelog from the official debian package as I want them.
- modified the prepare script to use changelog.debian_official if the username is hadess :) - added a --nocvs arg to the prepare script to force generating non-snapshot changelogs svn-id: r4336
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog.debian_official23
-rwxr-xr-xdebian/prepare8
2 files changed, 29 insertions, 2 deletions
diff --git a/debian/changelog.debian_official b/debian/changelog.debian_official
new file mode 100644
index 0000000000..55fc446a38
--- /dev/null
+++ b/debian/changelog.debian_official
@@ -0,0 +1,23 @@
+scummvm (0.2.0) unstable; urgency=low
+
+ * New upstream version (Closes: #143281)
+ * Killed the wrapper script, see upstream changelog
+
+ -- Bastien Nocera <hadess@hadess.net> Wed, 15 May 2002 03:27:11 +0100
+
+scummvm (0.1.0b-2) unstable; urgency=low
+
+ * Moved the scummvm main bin under /usr/lib, the wrapper script under
+ /usr/games
+ * Fixed bug in the script that made it not work if the path was relative
+
+ -- Bastien Nocera <hadess@hadess.net> Wed, 10 Apr 2002 19:27:05 +0100
+
+scummvm (0.1.0b-1) unstable; urgency=low
+
+ * Initial Release.
+ * Packaged made under the influence of beer at GUAD3C in Sevilla ! Arriba !
+ Ole !
+
+ -- Bastien Nocera <hadess@hadess.net> Fri, 5 Apr 2002 16:37:09 +0100
+
diff --git a/debian/prepare b/debian/prepare
index 63384fe647..0698be1184 100755
--- a/debian/prepare
+++ b/debian/prepare
@@ -5,12 +5,16 @@ if [ ! -e debian/rules ] ; then
exit 1
fi
-if [ -d CVS/ ] ; then
+if [ -d CVS/ ] && [ $1 != "--nocvs" ]; then
TODATE=`date +%Y%m%d`
NEXT_VERSION=`grep SCUMMVM_VERSION scumm.h | sed 's,\#define\ SCUMMVM_VERSION\ \",,gi' | sed 's,\ devel\",,gi'`
cat debian/changelog.cvs | sed s/@VERSION@/$NEXT_VERSION.cvs$TODATE/g \
> debian/changelog.tmp && mv debian/changelog.tmp debian/changelog
exit 0
else
- cp debian/changelog.debian debian/changelog
+ if [ x$USER = xhadess ]; then
+ cp debian/changelog.debian_official debian/changelog
+ else
+ cp debian/changelog.debian debian/changelog
+ fi
fi